powershell下安装带@的npm包报错问题

2019年03月06日Web后端

在自个win10的powershell下安装@material-ui/core时,一切都正常。但是在公司的win7电脑下用npm i安装时出现了报错,提示无法识别的标记。。。

一、问题

在powershell下,使用npm install安装带@的包都会提示出错,vs code下报错如下:

二、处理方法

使用cmd安装

powershell的@有其他的用法,所以改用cmd安装。

可以正常安装。

增加引号

如果执意要用powershell的话,可以给包名增加引号即可。

这样也是可以安装的。